1

UPDATE: I now realize my problem with pixelation occurs when I change the CRS to WGS 84 / UTM. Anyone familiar with why this would happen or how to avoid it?

ISSUE: I am having trouble with hillshade on a QGIS proejct I have been working on for some time. The hillshade I get using a DEM comes out with significant pixelation (See image below). I've used the same DEM in a separate project and I don't get the pixelation at all. I would start a new project except that I have very elaborate Map Themes set up in the original (problematic) project that I can't seem to transfer to a new project.

A stripped down version of the project QGIS files and layers can be found here: https://drive.google.com/file/d/1Kt6TwXI2SBzjjT21kUr2MJMXcTVV3YEp/view?usp=sharing

This is the process I use to generate the hillshade in a new project where I don't get pixelation:

  • Open a new QGIS project
  • Add the DEM as a raster file
  • In symbology
    • Set render type to Hillshade (directly from the dem)
    • Set resampling section to 'cubic' in the Zoomed in field.
    • set transparency to 50%
    • Click Apply

If I use the DEM with the above process I get smoothed hillshade from the DEM (no pixelation) but the same DEM produces a pixelated hillshade in my original project. I've tried eliminating all other layers to see if it's a layer conflict but the hillshade is still pixelated even when it's the only layer. It seems to me that there must be some setting or preference in the old project (linked above) that prevents me from smoothing the hillsahde using resampling.

Anyone have any idea how to fix my original project so resampling can be used to smooth the hillshade?

Here's a sample of the map with pixelated hilshade.

Map with Pixelated Hillshade

  • I assume you matched up the other raster settings in the rendering options, and the coordinate systems and transformations match too? As a workaround you might actually create a hillshade from the DEM and use that. Another workaround might be to try using the new project but saving your elaborate map themes as style files, or layer files, and then using them in the new project? – johns Jul 21 at 13:33
  • Thanks. I wasn't aware you could move map themes using style or layer files. I'll try that. – Matt Gunn Jul 21 at 15:01
  • Working with the project which does not display pixelation in the DEM hillshade I've determined the single property change that causes the pixelation to occur. It happens when I change the Predefined Coordinate Reference System in the Project Properties Panel. It is set to an Unknown CRS (features in the map are distorted with this CRS) when I first import the raster DEM (no pixelation). However, once I set the Predefined Coordinate Reference System to WGS 84 / UTM zone 10N (features appear normal in the map using this CRS) the hillshade becomes pixelated when viewed at 1:30,000. – Matt Gunn Jul 22 at 6:58
  • Any suggestions on how to change the CRS to make map features look appropriate without causing the hillshade to become pixelated? Thanks for any help. – Matt Gunn Jul 22 at 7:01
  • It is always best to use a DEM in its original coordinate system. As soon as it gets re-projected there is interpolation. Of course it's not always possible to find one in the desired projection. You could see if a hillshade created from the DEM works better, perhaps even creating a DEM or hillshade in WGS 84 to avoid reprojection on the fly. As for features looking distorted every coordinate system will change how they look. I work mostly in UTM so WGS 84 looks "distorted" with known features, but normal for other scales I use. – johns Jul 22 at 12:56
0

I once encountered this problem, my better solution was to go to the hillshade layer, right-clicked, in style resampling, selected bi-linear, changed oversampling. The image reduced the pixelation although it was somehow blurred but worked for me.

| improve this answer | |
0

Turns out I didn't have CRS for the project and the hillshade aligned. Once aligned I was able to get a smooth hillshade.

| improve this answer | |
  • You can edit your previous answer instead of adding a new similar one. – Kadir Şahbaz Sep 25 at 6:44
0

I've got it sorted out now. the issue was that I didn't have both the hillshade layer and the project layer in the same (correct) CRS. Once I had them both in the correct CRS the pixellation disappeared (using bilinear).

| improve this answer | |
0

Saw your request on upwork and came here.

Didn't you notice that your hillshade is the reverse? Valleys appears going up and mountains depressions.

I think your issue is resolved setting CRS to the tif. Reading file in ArcGIS says is epsg 4617 (NAD83, Canadian...)

Option 1. set original dem to 4617 -in QGIS layer properties-, generate hillshade in raster/analysis, can use multidirectional shading then all is ok also if we change project projection to 32610 less plain areas into the valleys, where undulating terrain is exaggerated and we get a gridded aspect. Solution to this would be to 'mask' this areas using raster calculator.

Option2. doesn't works, set raster to 4617, then reproject to 32610, calculate hillshade, you get gridded results for all the raster.

Option 3: Get same raster from other source in 4326 as Japan ALOS 30 m, https://www.eorc.jaxa.jp/ALOS/en/aw3d30/

When try to reproject between 4617 and 4326 or 32610 there is a lack of conversion files, you can download and apply this to ge good conversion, conversion grid size is 460 Mb.

CRS

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.