I have a problem loading and adding data from the following a WFS to my QGIS project:


I can connect to the service and see the data available. (See picture below)

Connection to WFS

But after adding a layer with the data to my project I get the following error and no data is displayed:

Layer ogdwien:FMZKGEBOGD: Download of features for layer ogdwien:FMZKGEBOGD failed or partially failed: Server generated an exception in GetFeature response: org.opengis.referencing.NoSuchAuthorityCodeException: No authority was defined for code "". Did you forget "AUTHORITY:NUMBER"? No authority was defined for code "". Did you forget "AUTHORITY:NUMBER"?. You may attempt reloading the layer with F5

As far as I know you don’t need an authority number to use the service since it is an open data service from the city.

I can export the data to a shapefile. But then some of the data is missing. In my case not all the buildings are exported, just some of them.

I am using Windows 10 and the QGIS Version before was 3.4.11. I now upgraded to the new version 3.14.1 but I still have the same problem.

  • I get the same message with QGIS 3.10.4 on Linux.
    – Zoltan
    Jul 25, 2020 at 15:44
  • Using the following URL I get the features: data.wien.gv.at/daten/…
    – Zoltan
    Jul 25, 2020 at 15:51
  • 2
    It's looking for an epsg code
    – Ian Turton
    Jul 25, 2020 at 16:06
  • I also tried adding the Epsg Code: 31256 to the layer but there is still nothing displayed. And in the Data Source Manager I can't change the Coordinate Reference System.
    – Malks
    Jul 26, 2020 at 9:25

1 Answer 1


The issue here is the how the DefaultCRS is advertised in the WFS version 1.1.0 (and higher WFS versions), that is like:


Which does not resolve.

In the WFS 1.0.0 response you have instead a more recognised shorthand:


The AUTHORITY:NUMBER reference here is to the CRS authority, for example ESRI, OGC, EPSG... and the associated number.

In QGIS, you can choose which version of WFS to use for the service end point, in this case just https://data.wien.gv.at/daten/geo?

Choosing version of WFS

and in doing so can overcome the problem with the service to give us output like:

Open Government Data WFS Wien, WFS in QGIS

  • 1
    Thank you very much. That solved my problem. And also thanks for the good explanation.
    – Malks
    Jul 28, 2020 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.