The identify features tool returns the wrong selection when I try to select multiple features. In the image, I am trying to select the orange region, but QGIS is identifying the red region (located right above the popup window).

Identify Features Incorrect Selection

Note that clicking a single feature works correctly, only the "click-and-drag" works incorrectly.

I have tried the following:

  1. Using GeoPandas to convert the shapefile (originally in ESRI:102003) to EPSG:4326 before loading into QGIS. This does not allow me to select any features at all with the "click-and-drag" method (even when the project CRS is EPSG:4326). This change in behvaior makes me think the issue is with some CRS setting.
  2. Updating QGIS to 3.14.1
  • I can't reproduce the issue, so probably it is a CRS issue, yes.
    – Erik
    Jul 27, 2020 at 14:59
  • I'd check the geometries for validity errors - these can cause undefined behaviour like this
    – ndawson
    Jul 27, 2020 at 19:37
  • @ndawson Thanks. I just ran the Geometry Checker Plugin to check for validity errors and am still having the same issue on the valid geometries. Jul 27, 2020 at 20:02
  • As per the help center it is OK to try and reproduce software problems in a Q&A here, but if you think this is a bug then be sure to submit it to the QGIS development team. Please post a link to the bug report here.
    – underdark
    Jul 29, 2020 at 19:58
  • 1
    @underdark Thanks. I have now posted it here github.com/qgis/QGIS/issues/38052 Jul 30, 2020 at 17:01

1 Answer 1


If anyone else runs into this, I fixed it by resetting my user profile in settings>user profiles>new profile

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.