0

I have a remote WFS service from ArcGIS.

http://<my-domain>:6080/arcgis/services/MyFolder/WFSDemoService/MapServer/WFSServer?service=WFS&request=GetCapabilities&version=1.0.0

I create a WFS store in GeoServer and have no problem with publishing layer from this service to GeoServer. I have a problem with showing a WMS of these published layers.

When I call WMS request manually, GeoServer logs is something like these:

My request:

/geoserver/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&FORMAT=image%2Fpng&TRANSPARENT=true&LAYERS=my_layer&STYLES=SampleWorldCities_cities8367&DATE=1596003527070&TILED=true&WIDTH=256&HEIGHT=256&SRS=EPSG%3A3857&BBOX=-10018754.171394622%2C0%2C-7514065.628545966%2C2504688.5428486555

error log:

ERROR [data.ows] - Failed to execute request 
http://<mydomain>/arcgis/services/SampleWorldCities/MapServer/WFSServer?PROPERTYNAME=Shape&FILTER=%3Cogc%3AFilter+xmlns%3Axs%3D%22http%3A%2F%2Fwww.w3.org%2F2001%2FXMLSchema%22+xmlns%3Agml%3D%22http%3A%2F%2Fwww.opengis.net%2Fgml%22+xmlns%3Aogc%3D%22http%3A%2F%2Fwww.opengis.net%2Fogc%22%3E%3Cogc%3ABBOX%3E%3Cogc%3APropertyName%3EShape%3C%2Fogc%3APropertyName%3E%3Cgml%3ABox%3E%3Cgml%3Acoord%3E%3Cgml%3AX%3E-90.17578125%3C%2Fgml%3AX%3E%3Cgml%3AY%3E-0.17578097424708533%3C%2Fgml%3AY%3E%3C%2Fgml%3Acoord%3E%3Cgml%3Acoord%3E%3Cgml%3AX%3E-67.32421875%3C%2Fgml%3AX%3E%3Cgml%3AY%3E22.105998799750562%3C%2Fgml%3AY%3E%3C%2Fgml%3Acoord%3E%3C%2Fgml%3ABox%3E%3C%2Fogc%3ABBOX%3E%3C%2Fogc%3AFilter%3E&TYPENAME=SampleWorldCities%3Acities&REQUEST=GetFeature&RESULTTYPE=RESULTS&OUTPUTFORMAT=GML2&VERSION=1.0.0&SERVICE=WFS
    2020-07-29 11:02:13,778 ERROR [geotools.rendering] - org.geotools.data.wfs.internal.WFSException: Exception parsing server exception report
    java.lang.RuntimeException: org.geotools.data.wfs.internal.WFSException: Exception parsing server exception report

full error log

When I use preview layer module in GeoServer I got these errors:

WARN [wms.map] - Failed to determine CRS axis order, assuming is EN
org.opengis.referencing.NoSuchAuthorityCodeException: No code "CRS:GC,DEF,CRS,EPSG,4326" from authority "Web Map Service CRS" found for object of type "CoordinateReferenceSystem".
        at org.geotools.referencing.factory.AbstractAuthorityFactory.noSuchAuthorityCode(AbstractAuthorityFactory.java:952)
        at org.geotools.referencing.factory.wms.WebCRSFactory.createCoordinateReferenceSystem(WebCRSFactory.java:207)
        at org.geotools.referencing.factory.AuthorityFactoryAdapter.createCoordinateReferenceSystem(AuthorityFactoryAdapter.java:802)
        at org.geotools.referencing.factory.AuthorityFactoryAdapter.createCoordinateReferenceSystem(AuthorityFactoryAdapter.java:802)
        at org.geotools.referencing.factory.FallbackAuthorityFactory.createCoordinateReferenceSystem(FallbackAuthorityFactory.java:640)
        at org.geotools.referencing.factory.AuthorityFactoryAdapter.createCoordinateReferenceSystem(AuthorityFactoryAdapter.java:802)
        at org.geotools.referencing.factory.AuthorityFactoryAdapter.createCoordinateReferenceSystem(AuthorityFactoryAdapter.java:802)
        at org.geotools.referencing.factory.ThreadedAuthorityFactory.createCoordinateReferenceSystem(ThreadedAuthorityFactory.java:731)
        at org.geotools.referencing.DefaultAuthorityFactory.createCoordinateReferenceSystem(DefaultAuthorityFactory.java:179)
        at org.geotools.referencing.CRS.decode(CRS.java:525)
        at org.geotools.referencing.CRS.decode(CRS.java:453)

I have GeoServer 2.11.0 and 2.17 and I test these in both of them I got same error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.