I am publishing approximately 40 layers from ArcGIS Pro 2.5 to ArcGIS Portal. They all have the same data source. Each layer has a numeric 'Year' field. In Pro, the numeric field is formatted without the thousands separator. However, when I publish it to Portal, the thousands separator comma formatting appears and the year is "2,019" rather than "2019" in the pop-ups and data table. How do I prevent this from happening upon publishing? I don't want to fix 40 layers. I need to refresh this data regularly.

I am also trying to avoid creating a new text year field and setting it to equal the numeric field because after that I will have to repeat the of hiding the old field and rearranging the order of the new fields step 40 times (once for each layer) before publishing it again to Portal.

3 Answers 3


Here is the manual way to fix this:

The formatting is governed by a setting in the webmap that uses these layers. Open your webmap with these layers in the Portal map viewer/editor. Click the ellipses (...) button to see more options. Choose the Configure Pop-up option. In the Configure pop-up dialog there is a link for Configure Attributes under the fields list. After opening this dialog you can see additional options for each field. If it is numeric there will be an option to uncheck 'Use 1000 Separator'. Turning this option off will show numbers the way you want in the map pop-up, attribute table and any widgets in use.

It may be possible to automate the workflow using the ArcGIS API for Python There is a popupInfo property for the layers.


The root cause of the problem (in my humble opinion) is that your data type shouldn't be a numeric field. A string field here would be more suitable, or - a formatted date field.

It sounds like you know this but I wouldn't go and create a new text field off the original numeric field. Change the data type of the numeric field. Whilst it will be more work to begin with, implementing customisations/code/work arounds in the downstream publication mechanisms is only going to cause on-going maintenance pain and is really just a cover up of the root cause of the problem.

A good approach might be to do both - Implement a temporary 'visual' fix in Portal as per other answers, such that end users get the aesthetic popup showing nicely formatted dates - whilst in the background, schedule the datatype change. Once implemented, rollback the visual datatype formatting.

  • 1
    Thanks, I'm just wondering how to change the data type of the field without creating a new field? Would that be done initially at the stage when I import the data from the csv/spreadsheet and can play with the fields?
    – user112188
    Commented Jul 31, 2020 at 13:05
  • 1
    You should be able to change the data type of the field, but it will depend on the data source. ie: The answer will be different if its a relational database, vs a Geopackage, vs a Shapefile, vs a geoJSON. Let us know what the source data is and we can put you on the right path.
    – nr_aus
    Commented Aug 3, 2020 at 5:43
  • Thanks and sorry for late reply. The source data is excel, converted to csv, which I then imported as a table to a gdb and join to a feature class.
    – user112188
    Commented Aug 13, 2020 at 15:24
  • So CSV have no concept of a data type, so im assuming your data is just '2015' ... but when you migrate to excel, it very well may be turning that into a number/integer ie: '2,015'.......So you will want to check there (maybe try and just go straight from csv to FGDB).... also here is a link on how to change your FGDB data type.... desktop.arcgis.com/en/arcmap/10.3/manage-data/geodatabases/…
    – nr_aus
    Commented Aug 14, 2020 at 1:50
  • To clarify, I receive the data in excel. I then convert the excel to csv, and then import it to fgdb.
    – user112188
    Commented Aug 18, 2020 at 13:43

Following @Rich Wawrzonek's advice, I could not find the "Configure Pop-Up" option, which is similar to what is mentionned in an ESRI technical article (How To: Remove the thousand separator from numeric fields in ArcGIS Online).

I was able to remove the thousands separator with this page: Configure fields.

  1. In the map viewer, select Fields in the toolbar.
  2. Select the field.
  3. You can then change the display name and hide/show the thousands separator.

Screen capture of editing field name and formatting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.