2

I have vector layer with WFS protocol. and because I have a huge amount of data, there is a while before features loaded on the map.

So i need to tell user to wait a moment until they load by display a "waiting" animation.

I found this Waiting for Vector & WFS loading

and tried it with no luck so far.

here is what I did:

  • I placed the LoadingPanel.js

  • I added this stylesheet:

    <style type="text/css">
    
    .olControlLoadingPanel {
    
            background-image:url(loading.gif);
    
            position: relative;
    
            width: 195px;
    
            height: 11px;
    
            background-position:center;
    
            background-repeat:no-repeat;
    
            display: none;
    
        }
    
     </style>`
    
  • and finally added the LoadingPanel control :

    map.addControl(new OpenLayers.Control.LoadingPanel());

1

1 Answer 1

2

could be your z-index? This works for me here

.olControlLoadingPanel {
background-image: url(../OpenLayers/theme/default/img/load.gif);
left:45%;
top: 45%;
position: absolute;
width: 250px;
height:250px;
background-position: center;
background-repeat: no-repeat;
display: none;
z-index: 1000;

}

2
  • Thanks, but does that work with vactor/wfs layer?
    – Shadin
    Nov 3, 2012 at 10:05
  • I think so. I looked at LoadingPanel.js and it seems to be activated by layers, not layer type.
    – geomajor56
    Nov 4, 2012 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.