0

I'm using ArcMap 10.6.1 and have 50 layers each with a validated definition query.

A typical layer definition query is: autocad_layer = 'Week 25 - Program Element 147.01.23 - 01-06-18'.

The data source is a file geodatabase on a AWS server with UNC path of

\\awsservername\ProjectData\ProjectA\GDBs

I want to publish the MXD as a map service but when I run the analyze tool in service editor I get a number of invalid layer definition queries. I have tried redefining the definition queries for the layers that report invalid ones but while those are accepted, new ones appear in the analysis window. I have tried running the analyze tool several times without changing anything and each time I get a different set of invalid layer definition queries listed.

What is going on here?

Anybody else had a similar issue?

My MXDs are on an AWS disk and I have published other services (without layer definition queries) from that location previously without an issue.

first try

second try

thrid try

  • You have a tag for ArcGIS Server but don’t mention that software in your question. Is it relevant? – PolyGeo Aug 2 at 1:50
  • I'm publishing the map service to ArcGIS server. – wunderkind Aug 2 at 2:18
  • 1
    Please Edit the question to specify the the data source of these layers, and provide a sample query definition. – Vince Aug 2 at 2:31
0

I have been working with our cloud team and we have discovered that the problem occurs because of a bad network connection/speed between my home office (thanks COVID!) and the cloud server. While is wasn't dropping out completely it seems that bad connectivity is to blame for these errors. The cloud team provided me with a cloud based workspace and I was able to publish all the mxds without these problem re-occurring and without changing any of the definition queries.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.