0

I have a model created in ArcMAP 10.8 modelbuilder that has an iterator (tables) (standard setup). The model is setup in such a way that it runs various analysis on multiple DBF files in a folder. The model has always worked but now it ignores all the DBF files in the folder as if its empty.

When the model has finished I get this message "NOT_RECURSIVE"

Please advice

  • How are you executing this tool? is it from a toolbox or do you open the model? From Catalog or Map? Is it possible that the model can no longer find the path that is set in the iterator or that one of the dbf files have become corrupt or locked? – Michael Stimson Aug 4 at 7:18
  • Its run from the toolbox via edit mode. I even tried to delete the iterator and select the dbf files manually but its as if they are not there – MSS Aug 4 at 7:51
  • Will they open in Excel? (but don't save) Can you view the contents in Catalog? Is edit mode necessary? Most geoprocessor operations don't require editing and it can become a hindrance. If the files look ok in Excel and Catalog try running the model from Catalog, after a quick restart of course, then ensure only one instance of Esri products is referencing the tables; even crashed sessions can keep locks until the next restart, most of the time unexplained errors are because of a persistent lock. – Michael Stimson Aug 4 at 7:59
  • They open in excel and seems completely fine. I cant see the files in catalog no. I also tried to reboot the PC but no change – MSS Aug 4 at 9:22
  • I figured it out, so each for each dbf I also had a cpg, prj, sbn, sbx and shb file. When they are all in the same folder, ArcMAP only saw them as a shape file collectively. However, when I copied all the dbf files into a seperate folder then ArcMAP could finally see them as dbf files. Everything seems to work fine now. – MSS Aug 4 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.