0

A grid vector was created over the map layer (EPSG:32636) and saved as with CSR EPSG:32636.

Then when I export it as KML, it the grid appears in a different country (Congo rather than Lebanon).

  • I tried to export the KML under different CSR (EPSG:4326, 3857 or 32636): same problem

  • I tried to create columns of latitude/longitude using $x and $y for each polygon of the grid but the columns remain NULL

Here is the link to the shapefile of the grid vector. https://drive.google.com/drive/folders/1z5vWO-f0cmdY0FGD1xh24voFsT3OhmBo?usp=sharing

Does anyone have an idea? I am sure there is something wrong with the CSR and I tried everything that I knew so far.

9
  • 2
    KML can only be exported to 4326. How did you create the grid? To what data type did you save it? Can you provide data examples? – Erik Aug 4 '20 at 13:15
  • Ok, Thanks Erik. I didn't know kml were only in 4326. I created the grid using the vector tools of QGIS (Create grid vector) and i saved it into ESRI shp file. I added the link to the file in the post. – jammah Aug 4 '20 at 13:32
  • What extent/bounding box did you set for the grid you created? Also, what happens if you load the kml back into QGIS? – Erik Aug 4 '20 at 13:40
  • I used extent of the target layer, which is the map of two districts. Yes, it works perfectly when I load it back to QGIS. – jammah Aug 4 '20 at 13:54
  • 1
    Erik, thank you so much. I went back to the file downloaded from Diva and it is good. Therefore the problem is due from an error during the grid creation. I can't explain why it appears in Congo. I am very grateful though for your help! – jammah Aug 4 '20 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.