3

According to this link, QGIS 3.10 and newer can create GeospatialPDFs. However, when I go to export through layout view, the box is greyed out. What am I doing wrong?

Edit: As someone below points out, this question has a workaround for PCs but Macs are out of luck. See: Export geospatial PDF from QGIS on Mac

More details: When I go to export PDF through the layout view, the box for Create GeospatialPDF (GeoPDF) is greyed out with the message "GeoPDF creation requires GDAl version 3.0 or later." I have tried manually updating my GDAL to the latest (3.1.2) and upgraded my QGIS from 3.10 to 3.14. The message persists. From past StackExchange messages, I see that there are a number of workarounds from before QGIS supported GeospatialPDFs, but I'm hoping to get this particular feature of the PDF export function to work. I'm using Mac OSX 10.14.6.

Screenshot of the About page: enter image description here

Screenshot of processing options menu: enter image description here

2
  • Can you share a screenshot of the About page, from the Help menu? – Gabriel De Luca Aug 10 '20 at 0:09
  • 1
    Certainly. Added to the post above. – Rose Aug 10 '20 at 14:28
2

Now with QGIS 3.16.0 version you can create GeospatialPDFs on Mac as stated on QGIS changelog. Related bug report.

0
1

In QGIS, got to Help > About and it should say 'Running Against GDAL/OGR' and then the version number. You can also check that your GDAL drivers are installed and correctly loaded into QGIS by going to

  • Processing > Options > GDAL

There is a PDF driver there for creating Geospatial PDF's Alternatively, you could just check the overall health of GDAL in your QGIS installation by simply running a simple GDAL Processing query (eg: Vector Information) on a layer, just to check that GDAL is working. (This would also help to troubleshoot whether its just the pdf being a problem or GDAL overall being an issue).

Windows QGIS installations also have two executables, im not sure if this is the case with Mac. There may be a second QGIS exe which is 'QGIS Desktop with Grass' - try running it with that.

Also just to confirm - I ran a Geospatial PDF from both the Project > Import/Export menu, and also the Print Layout dialogs, with QGIS 3.12 - so it does work in this version. (im running 64bit installation on Windows btw.)

EDIT Found another link which seems to refer to issues with GDAL versions. Try the answer which talks about installing from a different installer. https://gis.stackexchange.com/a/340042/165549

4
  • 1
    I've added screenshots of both my about menu and the processing options dialog box. It looks like Q is still running GDAL 2.4.1--not sure how to force an update on this. You mentioned "running a simple GDAL Processing query"--could you recommend a quick tutorial on how to do this? I code R (stats) but don't have any experience coding GIS. I'd be happy to add this information as well. – Rose Aug 10 '20 at 14:33
  • Under 'Processing' menu, select 'Toolbox'. Then scroll down the listing until you see the GDAL group, expand that and then select Vector Misc > Vector info processing tool. Double click on that. In the window that opens, just select a layer that is inside your project and run. ………. Also try running your installer again, and see if there are options to install GDAL as part of the installer. Also ive just found another post which looks similar, ill link in my answer above. – nr_aus Aug 11 '20 at 6:52
  • 1
    Thanks. It looks like your edit to another link has the answer: there's a work around on PCs but not for Macs. Here's the follow up to the follow up: gis.stackexchange.com/questions/345761/… Frustrating but at least I can now move on to the work arounds until they fix this. – Rose Aug 16 '20 at 19:34
  • thats a bummer! – nr_aus Aug 17 '20 at 3:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.