3

For some reason, when I add a CSV as a delimited text layer QGIS is not recognizing field names in the first row. This has only been happening the last week or so. I am pulling my hair out.

Below is a screenshot of the csv and a screenshot from QGIS. As you can see QGIS is actually reading row 2 (the first row of data) as the field names.

CSV fileQGIS screenshot

1
  • 1
    My guess is there are some characters in the name causing issues. First suspect would be the % sign, then maybe the brackets and the dash.
    – M Bain
    Aug 6 '20 at 1:27
7

Likely stating the obvious here, but just a sanity check, the Number of header lines to discard is set to zero, yeah? Field Options

2
  • OMG - cant believe I overlooked this! Somehow I had the number of header lines to discard set to 1......
    – SHANE D
    Aug 6 '20 at 2:44
  • I''ve never done anything like that! ;)
    – Stu Smith
    Aug 6 '20 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.