0

using QGIS 3.14.1 and Qfield 1.5.3 with a Samsung Galaxy TAB A (2016)

I have created a Project in QGIS for use in Qfield. I am able to open the project in QField on the tablet and edit the layers with no problem. However when I import the project back to the laptop and open in QGIS I get a message to handle bad layers for any layers I have edited (the rest are fine) and then when I navigate to the source of the layer I get an 'invalid data source' error and the layer won't open.

This happens whether I use Qfield sync to package the project or not.

File paths are set to relative.

I have tried using QGS rather than QGZ - same outcome.

I have made sure versions of QGIS and Qfield are up to date.

0

Solved it in case any one has the same struggle, all the layers need to be GPKG instead of SHP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.