3

I am running PostgreSQL 9.0 on Mac OS 10.5. I've installed postgis-pg90-1.5.3-1-osx through "Stack Builder" but still don't see postgis in my list of databases when I open PgAdmin. When I open my Qgis 1.7, I can connect to my postgres database and display all tables with no spatial geometry. However, when I try to query a non-spatial table, I get the following message "Your database has no working PostGIS support".


Unfortunately, the link http://www.kyngchaos.com/software/postgres is limited to "...Lion and Snow Leopard, 64bit only." I'm using Leopard (Mac OS 10.5). The link http://trac.osgeo.org/postgis/wiki/UsersWikiPackages provides two options. Both of these (http://yum.postgresql.org/repopackages.php) & (http://www.postgresonline.com/journal/archives/204-postgis15-install-yum.html) point to Linux installations. So, I'm still stuck. I've downloaded PostGIS 1.5 using Application Stack Builder 3.0.0 from PostgreSQL 9.0. It installs, but does not run.

1 Answer 1

4

I used this website to install the same version of PG you are using on my Mac.

http://www.kyngchaos.com/software/postgres

It includes instructions for PostGIS installation.

This is another website with more options:

http://trac.osgeo.org/postgis/wiki/UsersWikiPackages

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.