0

I am interested in creating a flood map using machine learning methods. I need the same number of columns and rows for each raster data or layer. However, although I used the same boundaries for cutting raster datasets, I have a different number of columns and rows. By the way, cell sizes are the same for all data.

3
  • I am using ArcMap 10.7.1 When ı using the "resampling" tool, cell sizes become equal with other data, columns and rows do not change significantly Aug 10, 2020 at 19:51
  • Take a look at clipping and snap to raster options in addition to resampling. The combination can help you ensure same exact dimensions. Aug 11, 2020 at 14:01
  • I am having the same issue. Using the Processing extent settings does not solve the problem. I have been trying with ArcMap and then used R (crop() and resample() ) but that does not solve the problem neither.
    – Ric_02
    Dec 14, 2020 at 9:04

1 Answer 1

1

In ArcGIS 10.8:

  • Use Extract by Mask;
  • Input Raster: the raster layer with the wrong # of columns and rows;
  • Input Raster or Feature Mask Data: the layer with the correct # of columns and rows; Output Raster: your choice;
  • Click Environment tab;
  • Click Processing Extent, and browse to the layer with the correct # of columns and rows;
  • Snap Raster should be the same layer (the correct layer);
  • Click OK;
  • Check the layer property--> Source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.