I'm using pygeoapi as my server, and I'm having troubles with the connection of QGIS (3.14.0-Pi). I can see the list of layers available when I connect with my server from QGIS, but when I add to the project the layer is empty (no data, no geometry) and it gives me the follow warning.

2020-08-11T08:58:48     WARNING    Cannot create temporary SpatiaLite cache.: GDALCreate() failed: OGR was built without libspatialite support
             ... sorry, creating/writing any SpatiaLite DB is unsupported

I don't understand if this is a problem in pygeoapi or QGIS. The only mention between pygeoapi and libspatialite is in the pygeoapi documentation, but this is a configuration for OSX and my server is in Linux Machine, and I don't know how to translate this.

So basically, if anyone have experience with pygeoapi, and the integration with QGIS I will love to hear

  • Does your OGC API Features server support GeoJSON output? are you loading the service as a vector/geojson layer?
    – nmtoken
    Aug 11, 2020 at 11:06

2 Answers 2


Sounds like something with your GDAL build. The question at https://gis.stackexchange.com/a/168921 seems to be a similar problem and might solve your problem.

  • Thank you for your answer (and thank you for pygeoapi) I found that but I was sceptical because of the date and the fact that “OGC API Features” are still very recent in QGIS. But I will check that, because now it looks like a problem in QGIS (gdal) and not with pygeoapi. Aug 11, 2020 at 12:02
  • This was the problem, now it works just fine, thank you. Aug 11, 2020 at 13:55

Did you try the following?

enter image description here

On my side, the layer display.

The WFS approach also works on my QGIS (3.14 Ubuntu 64 bits) e.g

enter image description here

Second approach is better as it will take care of paging whereas the first solution need to care about limit of features you retrieve.

  • Thank you for your answer, I tried that now and it worked! I was just trying to add the data using the WFS protocol of QGIS, and that finds the collections but does not add the data. Aug 11, 2020 at 11:55
  • OAPI features is not WFS protocol, it is a whole new architecture
    – nmtoken
    Aug 11, 2020 at 11:59
  • The second solution was the one I did and found myself with an empty table and that warning, now I tried with: “demo.pygeoapi.io/master” and I have the same problem, Can you see the data in Attribute table or queried when you add the WFS3? Aug 11, 2020 at 12:22
  • Yes, got the representation and the records with their attributes in the table. That's why @tomkralidis answered you have an issue with your GDAL. I do not reproduce your issue as my GDAL is "fine"
    – ThomasG77
    Aug 11, 2020 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.