1

I am currently having issues with the Eliminate Polygon Parts tool (Cartography Toolbox). I have an Advanced License and ArcGIS Desktop 10.6.1. I run the tool on a polygon feature class, in order to delete features < 20 m2. The resulting polygons look fine. However, there is quite a problem with the attribute table of the feature class - it gets messed up completely.

I have 4 fields (int_300 / tiefe_300 / pq_id / p_typ), containing coded information (short integers). Some of the fields and information was added using the arcpy.AddField_management() and arcpy.da.UpdateCursor() tools. The information in the fields need to remain the same for further processing, but they don't. Somehow the "shape_length" and "shape_area" fields get moved to "pq_id" and "p_typ" respectively, "tiefe_300" just gets lost / set to zeros. See screenshots below.

I have found Shifted columns after Eliminate Polygon Part at GeoNet about a similar issue, but it has no solution on offer.

I suspect that there somehow exists a dependency on the order of the fields... but since I add the fields during processing I cannot do much about the original order.

How can I solve this problem?

Before: before

After: enter image description here

4
  • 2
    Make sure you've downloaded and applied all the 10.6.1 service packs. There was one that dealt with polygon topology issues. – Vince Aug 11 '20 at 12:34
  • @Vince: thanks for the hint - unfortunately all new patches did not help. Maybe I'll update to 10.8.1 and see how this works. – dru87 Aug 12 '20 at 14:12
  • 1
    You should also repair polygon topology before running the eliminate. – Vince Aug 12 '20 at 14:22
  • @Vince the topology of the polygons is fine. The repair tool does not change anything. I found out that the problem is indeed the order of the attribute columns. When I export the feature class to a shapefile and reorder the attributes, such that the shape_length and shape_area columns stand last, the eliminiate polygon part tool works fine, without altering the columns. This is weird. How do I reorder the columns "in place"? – dru87 Aug 12 '20 at 14:54
1

The problem can be solved with a workaround as follows:

  1. Run the dissolve tool on the feature class (checking the 4 fiels that need to persist later on - like this, shape_length and shape_area are moved to the end of the attribute table
  2. Run eliminate polygon part tool after the dissolving - everything works well

This seems like a bug to me. It also exists in ArcGIS Desktop 10.8.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.