1

I am trying to install QGIS on a win 10 Desktop PC, on which QGIS 3 was running until Win 10 has been reseted and compeletly new installed. After the installation, the QGIS splash screen shows up (QGIS is ready) but the main window remains empty (-not responding-, as reported by some other users as well).

I have tried allmost all versions 3.10, 3.14, 64/32Bit and Installation with OSgeo4w - always the same result: QGIS not main window is not responding. I also have removed local Appdata before every installation, also all hardware drivers seem to be up-to-date.

Any Ideas or Suggestions? Are there any logfiles available, which might help to find the Problem? Are there any additional tools/ programs needed?

2
  • Ok. I found the issue. With the new Windows Installation unused usb ports show up with assigned letters in the Windows Explorer ( don't know why), which Qgis tries to Access, since these devices are not responding (also causing issues in the Windows Explorer), Qgis crashes as well. Solution for me was to deactive these usb devices in the Windows Hardware Settings. - Now Qgis runs again very well.
    – Bennip
    Aug 12 '20 at 18:39
  • MS changed obvioulsy the policy for USB Devices with Windows 10, version 1809, docs.microsoft.com/en-us/windows/client-management/….
    – Bennip
    Aug 12 '20 at 21:58
2

I have almost the exact same issue. I do not have USB ports recognized as new drives, but it turns out I do have a network drive that is currently down but still appears as a lettered device on my machine. QGIS was hanging while trying to connect to this remote drive that is not responding. I disconnected my network, and QGIS launched immediately. I then went into the browser and told QGIS to ignore the failed drive. Problem is now resolved and QGIS boots normally.

0
1

I had the same issue with a shared drive and QGIS 3.20.3 on Windows 10 (21H1). The splash screen was not responding but saying "QGIS ready!".

The issue was that I was not connected to the VPN and therefore did not have access to a mapped share drive. As soon as I connected to the VPN, QGIS started without any issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.