2

I'm trying to install GeoPandas using the Command Prompt terminal. I have Python 3 and ArcGIS installed. I keep getting these messages that say there is a conflict with various packages. For example:

Package jupyterlab_launcher conflicts for: jupyterlab -> jupyterlab_launcher[version='<0.2|>=0.10.0,<0.11.0|>=0.11.2,<0.12.0|>=0.13.1,<0.14.0|>=0.6.0,<0.7.0|>=0.5.4,<0.6.0|>=0.5.4|>=0.4.0|>=0.3.0|>=0.2.3|>=0.11.0,<0.12.0'] _ipyw_jlab_nb_ext_conf -> jupyterlab -> jupyterlab_launcher[version='<0.2|>=0.10.0,<0.11.0|>=0.11.2,<0.12.0|>=0.13.1,<0.14.0|>=0.6.0,<0.7.0|>=0.5.4,<0.6.0|>=0.5.4|>=0.4.0|>=0.3.0|>=0.2.3|>=0.11.0,<0.12.0']

I used both conda install -c conda-forge geopandas and conda install --channel conda-forge geopandas.

5
  • 1
    Is it ArcGIS Desktop or ArcGIS Pro? – ahmadhanb Aug 12 '20 at 6:38
  • Have you tried conda install geopandas? – Aaron Aug 12 '20 at 7:30
  • The ArcGIS Pro envs have a few pinned packages that can cause conflicts when trying to install from conda-forge. Try just the default as suggested by @Aaron, or create a separate non-ArcGIS env – user2856 Aug 12 '20 at 8:07
  • Have you cloned or created a new environment? Per Python Package Manager, since Pro 2.2 you cannot install into the default environment. – KHibma Aug 13 '20 at 11:51
  • I was getting this yesterday. Had to install the full Anaconda programme to fix it. – Owen Aug 26 '20 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.