3

I am attempting to create a 100% MCP in QGIS using the minimum bounding geometry tool in QGIS. My data is sensitive and I therefore cannot share any of it (including a subset). I have used a dataset of animal locations as the input layer, left the field open as I need an MCP for all individuals together, and have chosen the "convex hull" geometry type. However, the output clearly ignores some of my location points (see left-hand side of the photo).

I have tried redoing this multiple times, even re-importing the point dataset, yet I still get the same result. I also tried creating a 100% MCP in R and then importing a shapefile of it into QGIS, and it still looks the same. Has anyone ever had this issue come up? I cannot seem to find anything wrong with the few points it's ignoring, so I am not sure what else it could be.

enter image description here

3
  • If the distances are long and it the CRS is EPSG:4326 something like that might happen due to curved lines following the great circle. If distances are short and CRS some projected system the issue must be somewhere else. Try if you can create test data by digitizing manually points into any other place in the world. – user30184 Aug 13 '20 at 7:39
  • Thank you, I tried adding an extra point even farther out than the cluster and the minimum bounding geometry tool still ignores it. The points cover quite a large distance and I have the project CRS set as "NSIDC sea ice polar stereographic north". Any other thoughts? – user168476 Aug 13 '20 at 16:39
  • 1) Points in Vector>Processing geometry>Triangulation Delaunay; 2) Editing and manual removal of unnecessary triangles; 3) Vector>Geo-processing>Uniting on the basis of... – Cyril Mikhalchenko Aug 13 '20 at 18:03
0

Did you try using all the convex hull algorithms available in QGIS? You can find below the choices you have. It may not answer of the why it fails but you may be able to solve your problem using an alternative algorithm.

enter image description here

4
  • Oddly they all still make the same shape! – user168476 Aug 13 '20 at 16:31
  • "I have used a dataset of animal locations" Available where? So we can try ourself. Clearly curious – ThomasG77 Aug 13 '20 at 17:46
  • I cannot share this dataset. It says so in the original question. – user168476 Aug 13 '20 at 22:56
  • Sorry. Misunderstanding when reading: I was thinking the sensitive data was something else. – ThomasG77 Aug 13 '20 at 23:08
0

I ended up just manually adjusting the polygon by snapping vertices to the outer location points that the tool was ignoring - crude, but it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.