1

I have a shapefile in EPSG:27700 with the linestring coordinates of locations in Scotland and trying to match them with a satellite image provided as a TIFF file with EPSG:4326 that has been taken from a satellite.

When I try to overlay the two layers on QGIS by setting the project CRS to EPSG:27700, the two layers don't exactly match as you see on the image, they are actually off by a bit.

I've tried using both EPSG:4326 and EPSG:27700 as the project default CRS but no matter which one I used, the layers still did not match.

Datum transformation used:

Inverse of OSGB 1936 to WGS 84 (9) + British National Grid +proj=pipeline +step +proj=unitconvert +xy_in=deg +xy_out=rad +step +inv +proj=hgridshift +grids=OSTN15_NTv2_OSGBtoETRS.gsb +step +proj=tmerc +lat_0=49 +lon_0=-2 +k=0.9996012717 +x_0=400000 +y_0=-100000 +ellps=airy –

Would the solution be trying to use a custom projection instead?

enter image description here

7
  • 1
    Please decide which software you are using. Also describe, what you tried to solve the issue, as well as give some background on the data.
    – Erik
    Aug 14 '20 at 10:57
  • What is the shift in position?
    – nmtoken
    Aug 14 '20 at 11:40
  • the shapefile is 15m east and 5m south of the image Aug 14 '20 at 11:49
  • 2
    This sounds like it may be a datum transformation issue, though I would expect hundreds of meters in that case. What transformation are you applying?
    – Vince
    Aug 14 '20 at 12:31
  • 1
    Please Edit the question in response to requests for clarification.
    – Vince
    Aug 14 '20 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.