3

Recently QGIS (currently using 3.10 A Coruna) hangs/stalls on startup. When I start the program, the splash screen appears and it runs through all the preliminary installation processes (JavaScript, plugins, etc.), then just hangs and doesn't actually open the QGIS program. The splash screen says "QGIS Ready!", but then, the program doesn't open.

The only way I have managed to solve this is to uninstall the program, reboot, reinstall, and then start the program. It starts correctly the next time, but then when I close it and shut down the computer, the next time I boot the computer and start QGIS, it just hangs like this.

I hate having to reinstall QGIS all the time.

Any suggestions about how to correct this problem without having to reinstall?

Screencap of stalled QGIS

3
  • 2
    Have you had a look at the bug reports? Have you searched the web for similar problems? Have you changed anything to your installation, which might have caused the issue? Can you return to an older, working version? Have you tried a clean installation? etc, pp.
    – Erik
    Commented Aug 14, 2020 at 12:07
  • 3
    You could try deleting the QGIS profile after uninstalling and then reinstall. On Win10 it is located at C:\Users\yourusername\AppData\Roaming\QGIS\QGIS3
    – MrXsquared
    Commented Aug 14, 2020 at 12:12
  • MrXsquared, this seemed to work for me. Thanks. Commented Aug 27, 2020 at 19:19

4 Answers 4

11

There is parameter named hiddenPaths in QGIS config file which usually located in C:\Users\*UserName*\AppData\Roaming\QGIS\QGIS3\profiles\default\QGIS\QGIS3.ini for Windows users. It can be used to hide network drives and printers from QGIS browser without having to disable this devices. Changing of this parameter solved my problem identical to yours problem described in this topic.

Example:

[browser]

hiddenPaths=Q:/, S:/, T:/, U:/, V:/
1
  • This worked for me in 2024. Thanks!
    – Kit
    Commented Feb 12 at 10:37
4

I've had the exact same issue. Turns out it was a mapped network drive that was unresponsive due an unrelated problem. After I've removed the mapping, QGIS started normally. No idea why QGIS was trying to access that drive even after I've deleted the QGIS directory from AppData\Roaming.

0
3

QGIS would not open, hangs on Ready. When I powered off my printer, QGIS would open properly.

My printer has two memory card slots - Y: and Z: drives on my system. They are empty, no card inserted. With the printer powered off, in the QGIS browser, I right clicked on each and selected "Hide from Browser". Problem solved.

QGIS now opens with the printer powered on.

1

I have recently had the same issue with QGIS 3.30.x and it turned out to be an issue with my QGIS profile (though I'm not sure what exactly got messed up). It was not an issue with a plugin as I have removed them from the profile folder first but something else and I do not have mapped network drives at the moment either.

Deleting the entire default QGIS profile folder (you'll usually find it in C:\Users<yourusername>\AppData\Roaming\QGIS\QGIS3\profiles on Windows) solved the issue and QGIS starts normally again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.