1

I'm working on exporting projects from QGIS to QField for data collection. I have read the documentation that requires the CRS to be the same for the layers and the overall project. The project is in WGS84-EPSG:4326 as are my layers. The basemaps are in EPSG:3857 - WGS 84 / Pseudo-Mercator. If I change this in the Layer Properties for the base map my project ends up in the ocean off the coast of Africa. If I change the Project CRS to EPSG:3857 - WGS 84 / Pseudo-Mercator, the layers end up in some unknown place.

How can I do this?

I usually work in GA83-WF (USA-Georgia-West) in AutoCAD Map3D and then move in and out of QGIS.


  1. Add your data and basemap and adjust symbology. See the Resources section of this document for QGIS tutorials. a. PLEASE NOTE: You will want to make sure your data layers are saved with the same CRS as your project in order for them to show up properly in QField. If you want to use a basemap, it is best to set your project CRS to EPSG: 3857 (WGS 84/Pseudo-Mercator) since popular basemaps you can access through QuickMapServices in QGIS use this CRS.
5
  • Where does it say that the CRS is required to be the same for the layer and overall project? – Matthias Kuhn Aug 15 '20 at 11:17
  • And one more question: the observation that things end up where they should not is in QGIS or QField? – Matthias Kuhn Aug 15 '20 at 11:18
  • Matthias,It was in this PDf that was linked from the QFIELD documentation 3. Add your data and basemap and adjust symbology. See the Resources section of this document for QGIS tutorials. a. PLEASE NOTE: You will want to make sure your data layers are saved with the same CRS as your project in order for them to show up properly in QField. If you want to use a basemap, it is best to set your project CRS to EPSG: 3857 (WGS 84/Pseudo-Mercator) since popular basemaps you can access through QuickMapServices in QGIS use this CRS. – Sigwood Aug 15 '20 at 22:17
  • And one more question: the observation that things end up where they should not is in QGIS or QField? It is in QGIS once I changed the CRS. No map has ever shown up in QFIELD. – Sigwood Aug 15 '20 at 22:22
  • You do not change the CRS in the layer properties, unless the layer is displayed incorrectly. Always reproject/transform the data to the desired CRS. – Erik Aug 18 '20 at 8:06
2

QField - like QGIS - can deal with mixed CRSes in a project. Now that we know this, we can reduce it to a (Q)GIS only topic.

If project and layers are in different CRSes a "reprojection" takes place automatically. This reprojection transforms coordinates from one CRS to the other one. Many of these transformations are not perfect, some data (precision) is lost along the way, you may be a part of a mm or many m away from the original location. This greatly varies on which CRS we talk about. Maybe the suggestion on the PDF was done with this in mind (impossible to say without knowing more about it).

This means:

  • You can just use your project and layers in whatever CRS you have. Depending on the use case the transformation imperfection is totally acceptable.

  • You can also align the CRSes of a layers beforehand. However, this cannot be done by simply "changing" them, they need to be reprojected. QGIS can also be used to reproject layers. It's like switching from meters to inches, you cannot just change the unit, the values have to be trasnformed as well.

You can read more about CRSes in the QGIS documentation.

4
  • Matthias, Thank you for your quick reply. I'm very new to GIS from a long time in CAD. I do not have a clear understanding of Datums and how they work. I have been able to get things to work by trial and error. I will investigate your link in the next few days and get back to you with my results. – Sigwood Aug 15 '20 at 22:58
  • Matthias, I decided to begin with a new project and start fresh. I began by creating a new layer from new shapefiles and the first one opened a conversion window with some options. I selected the proper GEO Location information for my file and added it to the project. The rest of the new layers automatically converted to the same GEO information and I then added my basemap. My basemap is now showing up in QFIELD as desired. Problem solved. We will assume operator error for the earlier problems. Thank you, Frank – Sigwood Aug 17 '20 at 17:20
  • 1
    And don't forget to accept the answer as correct and upvote if it helped. – Matthias Kuhn Aug 17 '20 at 17:31
  • 1
    Please don't add "thank you" as an answer. Instead, accept the answer that you found most helpful. - From Review – Vince Aug 17 '20 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.