I am currently trying to make a split graduated/proportional symbol map on Classical music composers by country and musical era and I am having trouble with making the symbol in QGIS.

I had to make a .csv-table consisting of the totals by country and by era, and I am able to join my this table to a shape file of European countries, but the desired column (totals, representing the total composers of each country from the entire span of all musical eras) from the joined table I want to show represent with the graduated symbol does not show up in the drop down bar on either program.

I am able to get the split symbol using the pie graph feature on QGIS, but I still would like to be able to represent size changes of each pie graph showing the total composers from all eras.

  • Screenshot(s) would sure help me visualize your issue!
    – Stu Smith
    Commented Aug 17, 2020 at 1:20
  • Did you check the data type of that totals?
    – Taras
    Commented Aug 17, 2020 at 6:01

1 Answer 1


I think Taras above has alluded to the correct answer.

On the layer properties of your country layer, if you go to the 'Fields' tab, it should list any joined fields. in this instance, the 'totals' field. I suspect in your case that the field type will be 'text'. Because it is a text field type, QGIS cannot perform a 'Graduated' styling. It needs numbers! I just did a small test of creating a dummy csv file with numbers, imported it into QGIS and joined it to some polygon data. I experienced the same problem as you, the join fields are not available in the drop down of the graduated style menu.

It appears that QGIS will always import CSV file as string data types. See discussion here QGIS 3.2 - Forcing column type when importing csv

The solution seems to suggest using a CSVT file format, to enable the data type to be specified during import.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.