1

I'm trying to get started with QField. I created a SpatiaLite database with several SpatiaLite layers in my QGIS project. Exporting that project with QFieldSync is super easy, as is (offline) editing the data in QFIELD on my tablet. When I import and synchronize the data back to my QGIS project all the data is there and everything seems fine. However, the source path of the SpatiaLite layers has changed:

Original path: C:\Users\...\Documents\Demo.sqlite

Path after synchronization: C:\Users\...\QField\import\demo2\Demo.sqlite

The original data is thus not synchronized, instead a new file with the same name but in a different location is created.

My questions are:

Is this supposed to happen?

If yes, what is a smooth way to make sure the original data gets updated as well?

If no, what should I do differently?

1
0

In QGIS, go to the tab "Plugins" -> QFieldSync -> Preferences. Here you can change the default import location.

To sync data back from your mobile device, you need to open the original project in QGIS and then sync it with the plugin.

If it is still not working, you may report the issue directly to the developers in GitHub

1
  • 1
    I changed from SpatiaLite to GeoPackage and the problem seems solved. – mitch Aug 26 '20 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.