3

I've been using QGIS 3.14 version to snap geometries to layer.

Parameters: Tolerance is 0.6m and behaviour: prefer aligning nodes, insert extra vertices where required

When I try to run this, I have to fix the geometry first before I run select by location.

I checked the output, most are correct but there are lines that did not snap correctly within the tolerance limit I set like this: (The distance in the photo is not even 0.001)

enter image description here

Is the manual way the only way to fix this?

6
  • Is the line on the last picture the original line or the line output of the process ?
    – Kalak
    Commented Aug 28, 2020 at 7:10
  • Have you experimented with the behavior drop down list?
    – Erik
    Commented Aug 28, 2020 at 7:31
  • @LouisCottereau it's the output of the process
    – leighmedy
    Commented Aug 28, 2020 at 9:23
  • @Erik yep. in this particular line, it still does not move.
    – leighmedy
    Commented Aug 28, 2020 at 9:39
  • If feel like Prefer closest point, insert extra vertices where required should remedy your problem, but I can't verify this without example data.
    – Erik
    Commented Aug 28, 2020 at 9:56

1 Answer 1

1

The snapping is only done relative to the original line: enter image description here enter image description here This snapping is set to 0.220 meters and as you can see some points are really close to the snapped line but more than 0.220 meters away from the original line so the line doesn't snap to them.

enter image description here enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.