1

I have been using a Python/ArcPy code use to generate many Excel files (.xlsx) from shapefiles. After the last Pro update end users start complaining that they get message when they try to open those Excel files.

First, I thought it was something wrong from my end, code, server etc. but when I do the process manually. I got the same error.

When I try to open ESRI generated Excel file I get the message below

enter image description here

Then I click Yes and get this message

enter image description here

It seems nothing get lost but it is frustrating popping multiple windows and make users think they did something wrong or something wrong with the file itself.

I found this https://stackoverflow.com/questions/18539267/xlsx-error-removed-records-named-range-from-xl-workbook-xml-part-when-tried/44416204#44416204

but I don't have any control of the template or problem mentioned here.

Is there way to fix our own or we need ESRI to fix that?

  • 4
    Have you actually fired this off to ESRI support? If you don't nothing will get done. – Hornbydd Aug 29 at 16:18
  • @Hornbydd I shared it at GeoNet. Hopefully, they will address the issue soon. – Amadeus Aug 29 at 17:54
  • 1
    Even GeoNet isn't the right place for bug reports. An actual bug report will tag a defect to your customer ID, allowing you get status reports as the defect is resolved. – Vince Aug 31 at 2:04
  • It's an issue with openpyxl which is a non-Esri python library that is included ArcGIS Pro's python environment. Can you edit your question and include the openpyxl version (the simplest way to find this is open the ArcGIS Pro python window and type import openpyxl;print(openpyxl.__version__) and your ArcGIS Pro version. – user2856 Aug 31 at 5:08
  • @Vince Unfortunately, I can not report bugs ESRI directly but I requested permission for the future problems. Thank you! – Amadeus Aug 31 at 16:22