3

I have a raster dataset that is not visible in Data View, but it is listed in the Table of Contents.

I have tried viewing it in ArcCatalog but it is not visible there either.

Is there something I can do make it visible so I can perform further analysis?

2
  • 1
    I'm assuming that you have tried Zoom to Make Visible from the layer context menu. Perhaps expand on your question by telling us what ArcGIS version and image format you are using. Can the raster dataset be opened and displayed in any other raster packages? Maybe it is corrupt.
    – PolyGeo
    Oct 23 '12 at 3:13
  • I'm having the same issue. I have tried Calculate Pyramids and Calculate Statistics, I have also tried exporting the raster as an.img with the "use render" box checked, but I just can't get the raster to show even though it's in my table of contents. Can you help? Thanks!
    – mfigura
    Aug 19 '20 at 14:49
1

Here are some trouble shooting ideas for you:

  • Check the file size to make sure all of the data exists.
  • Calculate Pyramids in case your raster dataset is difficult to view because of a huge file size.
  • Calculate Statistics to ensure you are able to view the correct range of data.
  • Download a new raster dataset, preferably as a .img, as these are among the most stable raster formats.
5
  • 1
    I'm using version 10. It is in a FGDBR format. I should also point out that the values of the raster data has a High of 3.40282e+038 and Low -3.40282e+038. Oct 23 '12 at 4:27
  • Have you tried calculating stats and pyramids directly within the FGDB? Also, I assume you are working with a stand alone raster as opposed to a raster mosaic or catalog, correct?
    – Aaron
    Oct 23 '12 at 4:40
  • I did run the "build pyramid and statistics" tool, no change.Yes, it is a stand alone raster Oct 23 '12 at 4:47
  • Also, try exporting the FGDBR to .img format to help determine if the original raster is corrupt.
    – Aaron
    Oct 23 '12 at 12:15
  • The option to do so is grayed out Oct 23 '12 at 16:12
1

try to classify your symbology first than export your image checking the "use render" box. This will convert your pixel depth to 8bit wich will exclude this value. Check the Range of values that each cell can contain, in Desktop Help for more information about pixel detph.

0

I got a solution for the same question, after getting the same issue. Copy the raster file along with it's supporting files (.xml, .ovr) from the drive and paste on a different location. Then just change the extension , like if it is in .ovr format , l have changed it to .tiff.ovr, asit remains in other tiff files. Did the same for the .xml file also. It will show warning message, but then I am able to see it in arcmap like normal tiff file. Try, if needed, it might help.

0

I had the same problem. I had struggled for two days, and by testing a simple shapefile, I found that the Width/Horizontal resolution and the Width/Vertical resolution that I had chosen were too coarse, even if I put the 0.05. I changed it to a smaller size (0.0005), and it works well!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.