CRS transformation promptdelimited text fileI am using QGIS 3.14.15 on MacOS. I have added a delimited text layer (csv file converted from xlsx) as a new shapefile. It shows up on the "Layers" section at the bottom left but not on the map. If I click "Zoom to layer," it shows up but everything else disappears. When I undo it, the layer disappears again. Made sure coordinates were represented on X and Y axis. Any ideas?

enter image description hereadding delimited text layer [showing import of csv (part 1)][3]

when I click "Zoom to layer" it shows up, but everything else disappears

  • 3
    Welcome to GIS.Stackexchange Euan! Please add some screenshots of the add layer dialog, the loaded layer, and the attribute table so we can narrow things down
    – underdark
    Sep 4, 2020 at 16:35
  • Hi and thanks, @underdark ! I just added some images. Hopefully that helps? Sep 5, 2020 at 11:24
  • Yes, that helps! As bugmenot123 mentioned, the problem is with the CRS configuration of the biovailable layer. If you want / can share (a sample) of that layer, we can have a look at what the CRS should be.
    – underdark
    Sep 6, 2020 at 9:41

1 Answer 1


Your other layer has a wrong georeference. Your map is set to EPSG:4326 but your coordinate display shows coordinates that are rather UTM or something similar.

Fix that and your data will align.

You can test the validity by adding a rough outline of continents if you enter the text "world" in the coordinate display and hit the Enter key.

  • Hmm.. I went back and made sure to set the rest of the layers to EPSG:4326 and the new layer to the same coordinates system but it still didn't work Sep 5, 2020 at 12:22
  • 1
    Do not randomly override them to EPSG:4326, their CRS setting in QGIS must be the one their coordinates are actually in. Try reloading all layers in a fresh new project and before overriding anything, question if that is really what you need. Sep 5, 2020 at 14:46
  • I see, thanks. It looks like the original Greenland shapefile has no coordinate reference system set at all. Is that maybe the issue? Sep 6, 2020 at 12:14
  • Definitely so :) If you do not know its CRS try loading it, find a point you could identify on a OSM map and enter the coordinates of that point in projfinder.com and see if it gives you something reasonable (switch X and Y if unsure ;) ). Sep 6, 2020 at 13:11
  • 1
    My colleague was able to fix it by going back to the original excel file by converting the Lat Long (originally listed DSM) to decimal coordinates, converting it into a new .cvs, then uploading it in ARCGIS as a WGS 1984 and converting it to the coordinate system used on the original shp. The original shp has a custom coordinate system that might not be compatible with QGIS. Thanks so much for your help bugmenot123! You helped me explore the software which I already like a lot Sep 8, 2020 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.