0

I am working on Nighttime light data from NOAA. The study area is India at state level. After masking the raster, when I am trying to run the zonal statistics with raster and vector polygon layer (screen shot attached), the small window of zonal statistics just flickers and does not run. Though the log section says that 'Algorithm zonal statistics finished' but it does not run. It does not add any new columns in the vector polygon attribute table. The attribute table is as it is as it was before. I have been trying to run this for last two days, but it does not help.

What could be the possible reason for it? I am currently using QGIS version 3.12.enter image description here

3
  • Again tried on stable version. The small popped up window only flickers once on pressing the 'run' button but it does not execute and create any new columns in the polygon vector. Though the log section shows this msg....... – vishal katara Sep 6 '20 at 18:31
  • Algorithm 'Zonal statistics' starting… Input parameters: { 'COLUMN_PREFIX' : 'NTL_', 'INPUT_RASTER' : 'C:/Users/visha/AppData/Local/Temp/processing_a8cd37cc2d5d452d97b84162057ac0e1/f18b7a6d36c64d1796c27f15caf68884/OUTPUT.tif', 'INPUT_VECTOR' : '/vsizip/C:/Users/visha/Downloads/gadm36_IND_shp.zip/gadm36_IND_0.shp', 'RASTER_BAND' : 1, 'STATS' : [0,1,2] } Execution completed in 0.05 seconds Results: {'INPUT_VECTOR': <QgsMapLayer: 'gadm36_IND_0' (ogr)>} Loading resulting layers Algorithm 'Zonal statistics' finished – vishal katara Sep 6 '20 at 18:31
  • Please help. Stuck with this for long. – vishal katara Sep 6 '20 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.