1

The DataPlotly plugin is not loading correctly on flatpak QGIS 3.12 for linux mint 19.3. I am running python 3.6.9 but the plugin seems to be seeking another version. Can anyone point me in the direction of a fix that does not involve this?

A pip install dataplotly terminal command is also yielding an error

Couldn't load plugin 'DataPlotly' 

ModuleNotFoundError: No module named 'plotly'  Traceback (most recent call last):   File "/app/share/qgis/python/qgis/utils.py", line 312, in loadPlugin
    __import__(packageName)   File "/app/share/qgis/python/qgis/utils.py", line 743, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)   File "/home/eoin/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/__init__.py", line 25, in 
    from .data_plotly import DataPlotly   File "/app/share/qgis/python/qgis/utils.py", line 743, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)   File "/home/eoin/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/data_plotly.py", line 31, in 
    from DataPlotly.gui.dock import DataPlotlyDock   File "/app/share/qgis/python/qgis/utils.py", line 743, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)   File "/home/eoin/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/gui/dock.py", line 14, in 
    from DataPlotly.gui.plot_settings_widget import DataPlotlyPanelWidget   File "/app/share/qgis/python/qgis/utils.py", line 743, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)   File "/home/eoin/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/gui/plot_settings_widget.py", line 75, in 
    from DataPlotly.core.plot_factory import PlotFactory   File "/app/share/qgis/python/qgis/utils.py", line 743, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)   File "/home/eoin/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins/DataPlotly/core/plot_factory.py", line 14, in 
    import plotly   File "/app/share/qgis/python/qgis/utils.py", line 743, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level) ModuleNotFoundError: No module named 'plotly'


Python version: 3.7.4 (default, Nov 10 2011, 15:00:00) [GCC 9.2.0]  QGIS version: 3.12.3-București București, 82342615 

Python Path: /app/share/qgis/python /home/eoin/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python /home/eoin/.var/app/org.qgis.qgis/data/QGIS/QGIS3/profiles/default/python/plugins /app/share/qgis/python/plugins /usr/lib/python37.zip /usr/lib/python3.7 /usr/lib/python3.7/lib-dynload /usr/lib/python3.7/site-packages /app/lib/python3.7/site-packages /app/lib/python3.7/site-packages/numpy-1.14.3-py3.7-linux-x86_64.egg /app/lib/python3.7/site-packages/MarkupSafe-1.0-py3.7-linux-x86_64.egg
3
  • i have a working installation of data plotly in qgis in linux mint, the only line regarding plotly I wrote in the shell is pip3 install plotly
    – Elio Diaz
    Sep 7, 2020 at 22:36
  • @ElioDiaz that will work with QGIS installed using the qgis.org repo, but not the flatpak as I understand. Are you using the flatpak QGIS?
    – user2856
    Sep 7, 2020 at 23:12
  • @user2856, yes, you are right, I'm using the regular installation, I oversaw the flatpak information
    – Elio Diaz
    Sep 8, 2020 at 0:43

1 Answer 1

2

The QGIS flatpak documentation lists this method to install python modules:

flatpak run --command=pip3 org.qgis.qgis install the_package_you_need --user
1
  • Many thanks. This worked.
    – user55532
    Sep 8, 2020 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.