1

How can I install the 5.11.2 version of PyQt5 using the OSGeo4W setup in Windows10? The default version of PyQt5 installed from OSGeo4W is 5.11.3 which is different from the QGIS compilation version, as in the pictures below. OSGeo4W default pyqt5 version

QGIS compiled version of pyqt5

My problem is when I run pylupdate5 translation.pro to create a .ts file for internationalization of code I give this message:

Traceback (most recent call last):
  File "C:\OSGeo4W64\apps\Python37\lib\runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "C:\OSGeo4W64\apps\Python37\lib\runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "C:\OSGeo4W64\apps\Python37\lib\site-packages\PyQt5\pylupdate_main.py", line 21, in <module>
    from PyQt5.QtCore import (PYQT_VERSION_STR, QDir, QFile, QFileInfo, QIODevice,
ImportError: DLL load failed: The specified module could not be found.

So, after that, I manually uninstall PyQt5 5.11.3 and install the 5.11.2 version and run pylupdate5 translation.pro again and it works, but when I start QGIS this message appears:

Error message on launch:
Couldn't load SIP module.
Python support will be disabled.

How can I solve this?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.