1

This code returned imagery for two date ranges previously. It suddenly stopped working for the 2nd date range (2018-06 to 2018-09).

I explored setting the cloud cover threshold up to 99 and searching for various dates. No results for the L2A (COPERNICUS/S2_SR) product are returned for any time prior to 2018-12 currently. I have verified that L2A data exists for these dates. The search will return results for the L1C collection (COPERNICUS/S2).

Does anyone have any idea how to again access this data in GEE? Could the part of the collection have been moved?

// Get granules from S2 L2A collection w/in study area
var collection_1 = ee.ImageCollection("COPERNICUS/S2_SR")
    .filter(ee.Filter.lt("CLOUDY_PIXEL_PERCENTAGE", 30))
    .filterDate('2019-12-15', '2020-02-15')
    .filterBounds(studyarea);
    
var collection_2 = ee.ImageCollection("COPERNICUS/S2_SR")
    .filter(ee.Filter.lt("CLOUDY_PIXEL_PERCENTAGE", 30))
    .filterDate('2018-06-16', '2018-09-18')
    .filterBounds(studyarea);   
    
print(collection_1); print(collection_2);// generates JSON lists for images
1
  • Did switching from S2_SR to S2 solve your problem? I tried that as my solution and am still seeing missing bands of Sentinel data in the United States. Is this common?
    – user181095
    Apr 3, 2021 at 13:49

2 Answers 2

2

I also had this problem. You can use a more complete dataset changing:

ee.ImageCollection("COPERNICUS/S2_SR")

to the Sentinel-2 MSI: MultiSpectral Instrument, Level-1C

ee.ImageCollection("COPERNICUS/S2")

In my case it solved the problem

0

Please attach the whole script or at least add your studyarea, otherwise we can't see the region you are working on and the error you are getting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.