2
  1. I am trying to train a model and classify it using the "Classify Pixels Using Deep Learning" tool. I exported my training sample data for deep learning, but when I add that .emd-file to the tool, I get an error that reads "Cannot access file %s." I saved the .emd-file to the main folder of my project. I have write access to this location and tried saving and closing the software.

  2. I am classifying vegetation, soil, and water classes. I used the rectangle training sample polygon shape. Would this impact the classification if I am depending on classifying pixels and textures, but not shapes?

This is with ArcGIS Pro 2.6.

Has anyone encountered this before? I am not entirely sure what I am doing wrong.

1

Did you correctly install deep learning packages? Because I received same error message after I updated my ArcGIS Pro 2.6 from 2.5. I reinstalled the deep learning packages and it was solved.

When you update the app your previous Python environments become useless and you should re-install the libraries and modules. So every time you update the app, the Python environment needs to be updated. You can use below link to easily install Deep Learning modules and libraries:

https://github.com/Esri/deep-learning-frameworks

For your second question: While digitising a feature as a training sample, the sample geometries don't matter if you correctly mark the classes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.