3

I am running QGIS 3.14.16-Pi and am wanting to load the layers Telstra (Australian telephone company) provides on their GIS server. https://staging.gcm.telstra.com.au/gisserver/rest/services/Hosted/

I have tried the Vector tiles plugin without success. I am unsure of the syntax of the URL to enter into the Vector tiles plugin. i have tried these below, as well as removing various levels of the URL:

https://staging.gcm.telstra.com.au/gisserver/rest/services/Hosted/CATM_D_External_antenna/{z}/{x}/{y}.pbf https://staging.gcm.telstra.com.au/gisserver/rest/services/Hosted/CATM_D_External_antenna/VectorTileServer?f=jsapi

The data displays well on a browser when clicking through the ArcGIS JavaScript link https://staging.gcm.telstra.com.au/gisserver/rest/services/Hosted/IoT_CatM1/VectorTileServer

I am sure if it will load it is a simple format issue or use of another plugin.

3

Choose a layer, copy the URL and add /tile/{z}/{y}/{x}.pbf to it.

Then in the QGIS Browser -> Vector Tiles add that URL as a new connection

You can discover the tile URL by clicking on the layer then clicking the little JSON link at the top and looking at the tiles element.

In the example below I use "Hosted/Mobile_All_Outdoor (VectorTileServer)" layer.

enter image description here

enter image description here

enter image description here

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.