0

I have upgrade my QGIS from 3.14.1 to 3.14.16 and I get this error on startup.

Traceback (most recent call last):
  File "", line 1, in 
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\__init__.py", line 70, in 
    from qgis.PyQt import QtCore
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\PyQt\QtCore.py", line 24, in 
    from PyQt5.QtCore import *
ImportError: DLL load failed: Kan opgegeven procedure niet vinden.


Python versie:
3.7.0 (v3.7.0:1bf9cc5093, Jun 27 2018, 04:59:51) [MSC v.1914 64 bit (AMD64)]

QGIS versie:
3.14.16-Pi 'Pi', a235a149f0

Python pad:
['C:/OSGEO4~1/apps/qgis/./python', 'C:/Users/joeri/AppData/Roaming/QGIS/QGIS3\\profiles\\default/python', 'C:/Users/joeri/AppData/Roaming/QGIS/QGIS3\\profiles\\default/python/plugins', 'C:/OSGEO4~1/apps/qgis/./python/plugins', 'C:\\OSGEO4~1\\apps\\Python37', 'C:\\OSGEO4~1\\apps\\Python37\\Scripts', 'C:\\OSGeo4W64\\bin\\python37.zip', 'C:\\OSGEO4~1\\apps\\Python37\\DLLs', 'C:\\OSGEO4~1\\apps\\Python37\\lib', 'C:\\OSGeo4W64\\bin', 'C:\\Users\\joeri\\AppData\\Roaming\\Python\\Python37\\site-packages', 'C:\\OSGEO4~1\\apps\\Python37\\lib\\site-packages', 'C:\\OSGEO4~1\\apps\\Python37\\lib\\site-packages\\win32', 'C:\\OSGEO4~1\\apps\\Python37\\lib\\site-packages\\win32\\lib', 'C:\\OSGEO4~1\\apps\\Python37\\lib\\site-packages\\Pythonwin']

My toolbox processing is gone, I even cannot install anymore plugins, please help I need to get a certain QGIS model back.

0

There seem to be a range of issues for some users related to startup, python errors, and Processing or other plugins, in the latest Windows versions. It's not quite the same error messages you have, but see https://github.com/qgis/QGIS/issues/38914, https://github.com/qgis/QGIS/issues/38772, https://github.com/qgis/QGIS/issues/38720, https://github.com/qgis/QGIS/issues/38476

Developers seem to be saying they're fixed, but people keep reporting variations of the error.

Depending on your appetite to get your hands dirty, I'd suggest one of:

  1. Do a clean reinstall of QGIS, making sure you get 3.14.16-2 (or higher) for qgis, qgis-common, qgis-grass-plugin-common; qgis-grass-plugin7 3.14.16-3; and rbatch 149-5 (this probably unnecessary)

  2. Revert back to 3.14.15 or 3.14.1 (note the special version numbering for Pi - the version increments were 3.14[.0], 3.14.1, 3.14.15, 3.14.16)

  3. Try out the master (qgis-dev) development version, where bug patches should be more recent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.