0

My source data shapefile contains multiple attribute fields in Hebrew.

I dragged it into a new empty map in ArcGIS Pro and created a layer. The geometry and English fields of the attributes table are correctly displayed. The Hebrew ones appear as gibberish in latin characters.

I tried the same source file in QGIS. Once I set the layer encoding to Windows 1255, all fields were correctly displayed.

I don't seem to find in ArcGIS Pro any setting that allows to control the source file encoding.

Any ideas?

3
  • Thanx for the link. The article deals with ArcGis for Desktop and does not cover ArcGIS Pro 2.5 or later. Anyway, I don't really like the idea of altering the system registry just for the purpose of one shapefile. I hope to find a simpler solution without messing with my system's gutts :)
    – AlonTAU
    Sep 24 '20 at 17:58
  • 1) Anything that applies to old code tree should apply to the new tree 2) There are several nested links there, which includes the first option, the creation and content of a .cpg codepage file
    – Vince
    Sep 24 '20 at 18:47
0

Inspired by Vince's comments regarding the .cpg file, I further searched and found the very simple and effective solution. It works for my specific case but I guess it should apply for any other encoding:

Just open a new file in a text editor, write "1255" into the first line and save it as "shapefilename.cpg" in the "shapefilename" directory (where the other .shp, .shx, .dbf, etc. files are stored)

With the .cpg file in place, I dragged again the source file into the the map. This time ArcGIS Pro properly displayed the Hebrew fields.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.