2

Possible Duplicate:
Couldn’t load SIP Module

When I'm starting QGIS I'm getting the problem: "Couldn't load SIP module. Python support will be disabled." And there is also:

Python version: 2.6.5
Python path: ['/usr/share/qgis/python', '/usr/lib/python2.6'...]

I actually have SIP but my current python version is 2.7 so SIP located at /usr/lib/python2.7

So how can I set the right version of Python and Python path for QGIS?

P.S. export PYTHONPATH=/usr/lib/python2.7 doesn't work

marked as duplicate by whuber Oct 25 '12 at 10:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged or ask your own question.