I'm working with QGIS 3.14. First I created my two fields "x" and "y", then I activate them on the label/placement window and I begin to work on the map: I found that labels who are placed manually, move while I change my position on the map. That don't change the real position, it's just "virtually" to give us the possibility to see the polygon's name. But in my case it's slow down my work. How can i change this option.... I don't found.

Here are images to help you to understand that I'm trying to explain:

enter image description here enter image description here enter image description here

  • My labeIs are bound to coordinates yes. But I does'nt zoom in/out I'm just moving. And my scale is blocked to the real size for printing.
    – pilou
    Sep 28, 2020 at 15:40
  • 1
    Are you sure QGIS is using your X/Y attributes fields ? It doesn't seem to me, as it should not move from the coordinates you gave. Can you show the configuration panel with the position tab ? The X and Y field should be yellow and point to your fields.
    – gisnside
    Sep 28, 2020 at 15:40
  • Yes Is yousing x/y attributes fields. And I think if there is the blue rectangle, mean that the position is fixed ? and the x and y are yellow. I send you a image
    – pilou
    Sep 28, 2020 at 15:56
  • yes its strange indeed. The problem here is that your message is bound to be closed because it's not really a question but a bug problem we cannot reproduce and its not the way gis stack exchange works :( You should have a try on georezo (as it seems you're french), on the qgis list to get some help on this. If you need for here, I suggest you to take the tour to fully understand how to ask questions and useful tips : gis.stackexchange.com/tour
    – gisnside
    Sep 28, 2020 at 16:05
  • 2
    As you use around centroid as label placement could it be that QGIS use your data defined point like it was the centroid and place the label around it ? Try to set a fixed position setting or maybe you could try to use the geometry generator (the labelling one, see just above your reds quare on your second picture) to generate a point with your x,y field then set your label to a fixed position relative to this point
    – J.R
    Sep 28, 2020 at 16:14

1 Answer 1


A few checks :

Make sure your XY field are correctly pointed at in the Placement tab and that they are activated : Properties/ Label/Position/Coordinates (see below). The X and Y buttons should be yellow.

Placement tab

Make sure your XY fields are not NULL. If it's the case, the label engine will continue moving them following the default configuration like you show on your screenshots.

Or, try @J.R method by checking the "geometry generator" labelling + this expression :

make_point( "X" , "Y" )

geometry generator

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.