1

I have the following code:

When I run it:

conType = arcpy.mapping.ListLayers(imxd, "Construction_pt", df)[0]
print conType.dataSource
prints... "Database Connections\Edit - Editor.sde\Edit.SDE.Construction_pt"
and rest of program runs correctly

When another user runs it:

print conType.dataSource
prints... "\Edit.SDE.Construction_pt"
program crashes because cannot find path

My question is why is it only displaying the full path for me and not other users?

ArcGIS 10, Windows 7

  • 1
    Hard to tell like this. Maybe it is a arcgis.workspace problem. I ran into various problems not setting the ArcInfoWorkspace(). Even though this is under ArcGis 9x using the gp-object. – LarsVegas Oct 25 '12 at 15:37
2

Finally figured out how to fix this:

In ArcCatalog, Database Connections, Select the SDE, and right click and go to Connection Properties.

Under Connection Details make sure the transactional version is set to that of the user (ex: "SDE.tom" and not the "SDE.default".

After changing this it now works correctly for the user who was having difficultly before.

1

Have you tried using the CatalogPath method of the Describe object instead?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.