1

I have created a model using ModelBuilder in ArcMap 10.8 to do the following:

  1. Project point shape file to change coordinate system from A to B
  2. Add a field (X)
  3. Calculate field: !SHAPE.CENTROID.X! using python_9.3
  4. Add a field (Y)
  5. Calculate field: !SHAPE.CENTROID.Y! using python_9.3
  6. Table to excel.

Whenever I run the model it stops at "Project" and gives me the following error ERROR 999999: Error executing function. Create output feature class failed Failed to execute (Project)."

Why does it not work? When I do this manually it works.

enter image description here

3
  • Have you tried deleting Project and adding it again to your model? – BERA Oct 1 '20 at 11:02
  • That worked for some weird reason. However, now the model stops at "Add field" where I get the following message "ERROR 000229: Cannot open L:\XXXX Failed to execute (Add Field). – MSS Oct 1 '20 at 11:50
  • I suspect its some sort of file locking issue, your drive is L:\ , why not write to C:\temp see if that fixes it? – Hornbydd Oct 4 '20 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.