1

After using the Include margins from printer option of ArcGIS Pro to display printer margins on a layout, the Align Center option stops aligning to the center of the page and aligns to the left printer margin instead.

To see this try the following using ArcGIS Pro 2.6.2:

  1. Start ArcGIS Pro
  2. From its Start Page use Start without a template
  3. Insert a New Layout - I chose A4 from the ISO - Portrait category
  4. Use the Straight text tool to drag a rectangle in a similar position to that in the picture below

enter image description here

  1. Click on the page, away from the text, so that the text element handles can be seen
  2. On the Text | Format tab of the ribbon, use the Align split button from the Arrange button group to first Align to Page, and then Align Center. You should see the text move to the horizontal center of the page, which is to be expected.
  3. Use the Undo button on the Quick Access Toolbar to move the text back to its previous position
  4. Use the Layout tab of the ribbon to click on the Select Page From Printer button in the Page Setup button group (see picture below). I am doing this because I want to display the printable area on my page.

enter image description here

  1. Tick the Include margins from printer checkbox, and then OK. You should see dashed lines appear just inside the page border to show the printable area of the page
  2. Use the Text | Format tab of the ribbon again, to click Align Center again. This time you should see the text move to be aligned with the left print margin (see picture below), which is NOT expected.

enter image description here

I believe this to be a bug, which I will report to Esri's local support.

While awaiting a fix for it, is there a workaround?

1

I was able to workaround this bug by doing the following:

  1. On the Layout tab of the ribbon, I clicked the Size button in the Page Setup button group (see picture below) and chose a different page size. I think any would do but I chose A3 under ISO Sizes. The printer margins disappeared from the page.

enter image description here

  1. I used the Size button again to choose my original page size which was A4 under ISO Sizes
  2. I used the Text | Format tab of the ribbon to choose Align Center again. This time the Text centered horizontally on the page, which is what I wanted.

The workaround above removes the printer margins from the page and makes the alignment options resume working as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.