1

I am trying to export the contour lines of a topography from QGIS to DXF AutoCAD to generate a 3d model of it. The data comes from a source that has the elevation in FT. It matches with my coordinates system in plan but when I export it the Z Height remains in ft. How can I change that in QGIS so I get my model in meters?


Still having the same issue. Once I am in Rhino or Cad, elevation data is at scale but then the distances horizontally do not match at all (are scaled more than 10.000 times). Sorry to be such a pill... The file I am using to be more specific is this one https://geohub.lacity.org/datasets/contour-lines-2006.

enter image description here enter image description here enter image description here

1

First you will need to create a new field, it will contain the elevation converted to meters. Then use the processing tool, Set Z value (under Vector geometry). Change the Z Value to be data defined and set it to the new field you created with meters. Then click run.

set z value

Go to the Project menu to export to DXF (Project -> Import/Export -> Export Project to DXF). Put a name in the save as box and make sure to only export the layer you added the Z value. Please note that AutoCAD does not handle WGS 84 (latitude and longitude) coordinate system very well. dxf export

Open the DXF file in AutoCAD and those lines should have the elevation.

autocad 3d

4
  • This was really helpful altough I am still having an issue. When I exported the file into AutoCAD and open it, the Z height is correct altough X and Y coordinates shrinked (In plan it has the correct XY ratio but it is way smaller in scale). Do you know what could be the problem? Oct 16 '20 at 13:38
  • How much smaller is it? Do you have an approximate scale? Make sure you exported the correct coordinate system.
    – GreyHippo
    Oct 16 '20 at 15:31
  • In my images you will see EPSG:2272, make sure you change this to use the same coordinate system you are using for your data.
    – GreyHippo
    Oct 16 '20 at 20:44
  • It worked! Thanks a lot, The problem was that I was using WGS 84 and seems it is a CRS that Autocad does not support so It worked when I exported it using NAD83 / UTM 10 N Oct 20 '20 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.