I have a large inut raster geotiff map of size 12000x9000. I am running r.watershed to output a stream raster map. However it is much lower resolution, only about 960x711. How do I make GRASS GIS / r.watershed command output a matching size raster map of same resolution of my input?

  • 1
    You need to use g.region here (or the corresponding entry in the map legend context menu). For the concept, see grasswiki.osgeo.org/wiki/Computational_region
    – markusN
    Oct 18, 2020 at 21:43
  • 1
    @markusN Please consider adding your comment as an answer.
    – Aaron
    Oct 18, 2020 at 22:00
  • Which parameter is it - rows/cols or res or nsres/ewres? Oct 18, 2020 at 22:18
  • if your are concerned about 2D grid resolution and using square cells, go to "Resolution" tab > "2D grid resolution" box put 0.5 for a 50cmx50cm resolution. In commandline, this is 'res=value' parameter Oct 19, 2020 at 6:47

1 Answer 1


In general, GRASS GIS is ready for massive data analysis.

In your case, you need to use g.region, by using the corresponding entry in the map legend context menu (right mouse button on legend entry) or on command line (generic example):

g.region raster=your_raster_map -p

It will then use bounding box and raster resolution to set the computational region.

For the underlying concept, see https://grasswiki.osgeo.org/wiki/Computational_region .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.