1

I am trying to connect to an ArcGIS-10.3 FeatureService in QGIS 3.14 (Pi) recently installed. In the connection details window, I have the URL but in the "Authentication" part, in "configuration", only "no authentication" is available. There is no drop down options available. I need an OAuth2 authentication (the plugin is installed - I checked in the Authentication window in Settings - options - authentication, installed plugins).

2
  • From the "Basic" tab you can add the basic auth credentials. I do not see other options in my QGIS 3.14 but I do not have OAuth2 plugin.
    – user30184
    Oct 21, 2020 at 16:11
  • thank you, see my answer below. that basic tab is compulsory and then the right authentication method can be selected when back in the "configuration" window
    – newby5067
    Oct 21, 2020 at 23:33

2 Answers 2

1

thanks @user30184 for your answer. You are right, I had to do that Basic authentication step first before I could be taken to this screen where then, OAuth2 authentication becomes available and a token file needs to be uploaded (that was provided to me by the colleagues whose ARCGIS server I wanted to access). successful connection now ! enter image description here

0

If QGIS is giving right information, OAuth2 does not support ESRI Feature server. However, EsriToken should be supported but I do not see how to use it in the connection wizard.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.