I am using over 10 KML in Google Maps. When I increase the number of KMLs they load too late.

I use checkboxes to hide/show KML layers. With up to 5 KML layers, it worked fine. When I increase the size of the KMLs it's not working normally.

When I check "show", it shows but "hide" does not work ...

How can I solve this?

  • Your question is a bit vague. If you can provide any details or code samples, you will likely get more meaningful answers. The Google Maps Javascript API documentation does not describe any specific limitations around the number of KML file that can be rendered as layers: developers.google.com/maps/documentation/javascript/… I imagine your issue is either in the way you are loading the KML files, or the size/complexity of the specific KML files. Sean – SeanMaday Oct 28 '12 at 16:41

have you tried to transform your +10 kml-files into one kmz-file?

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. – Ian Turton Oct 29 '12 at 9:14
  • @iant: inho packing more kml into one does speed up things (e.g. a least time to download via www shrinks) – Kurt Oct 29 '12 at 13:22
  • when using google maps to load kml vs kmz, kmz is a alot faster – simplexio Nov 29 '12 at 8:40

thanks for answer.. This my web address..

login: user password: resu

map link

.. all unchecked checkboxes are kmls. / checked checkboxes is marker..

The KML => point and pipeline show/hide fine. but when checked others kml its showing but not hide ((

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.