0

When I tried to define the CRS of my raster layers env :

crs(env) <- CRS("+proj=lcc +lat_1=49 +lat_2=77 +lat_0=0 +lon_0=-95 +x_0=0 +y_0=0 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=m +no_defs ")

I got this error:

In showSRID(uprojargs, format = "PROJ", multiline = "NO", prefer_proj = prefer_proj) :
  Discarded datum Unknown based on GRS80 ellipsoid in CRS definition

Knowing that I'm using R 4.0.3 on Mac, and I didn't have this issue on the previous versions. Does anyone know how to handle this issue?

4
  • I tried your projection and didn't run an error in my machine, do you have gdal, proj and geos installed?
    – Elio Diaz
    Commented Nov 3, 2020 at 1:47
  • I have "rgdal", "geos" and "proj4" libraries installed and I keep having the same problem. For the library "PROJ" when I try to install it it shows this message: PROJ is currently non-operational since version 0.4.0.
    – user1988
    Commented Nov 3, 2020 at 2:05
  • I didn't have this problem in the previous R versions.
    – user1988
    Commented Nov 3, 2020 at 2:12
  • 1
    This is a non-error, just a byproduct of the move to WKT projection definitions. You can suppress many of the related errors by putting options("rgdal_show_exportToProj4_warnings"="none") in your Rprofile.site startup file or issuing it before adding any packages. Commented Nov 3, 2020 at 14:26

0

Browse other questions tagged or ask your own question.