0

In a Windows server there are ArcGIS Pro 2.4 and ArcGIS Server 10.7.1 installed. Both products are licensed. Moreover, FME server is also installed on that machine. There are 3 workspaces in the FME server that make calls to Python (ArcGIS server). 2 of them works and the third one is failing.

In order to find the root of the problem, the Python script on the 3rd workspace is run in a command window (for the sake of see it run):

enter image description here

I tried to run the other scripts (pretty similar to this one) and I had the same error.

I open a command window, open Python and run the line:

import arcpy

and got the same result.

After making a quick search, only found this reference to the error:

https://wiki.earthdata.nasa.gov/display/SDT/Run+arcpy+on+ArcGIS+Windows

It suggests that I should use Python from ArcGIS Pro, not from the server. But I must use the one in the server.

The weird, strange, crazy behavior is that 2 of the workspaces work, despite the fact that they also make use of the same Python and both import arcpy too.

Just to have it mind: FME server engines, run under a domain user, and the ArcGIS server runs under other domain user credentials (but I don't think that is related).

Any suggestion?

1
  1. Open the Registry Editor and in the path, HKEY_CURRENT_USER\Software\ESRI\ArcGISPro\Licensing, rename the string value SOFTWARE_CLASS_FN to something else.

  2. Open the Windows Command window again and, run the script. If ArcGIS Pro asks for the right license again, insert the string value in the registry.

  3. Another way is to use another operating system user who does not use ArcGIS Pro.

  • I will try steps 1 and 2. The described state is the step 3 – XtianGIS Nov 5 '20 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.