1

I'm trying to add a CSV with Lat/Lon to Google Earth Engine.

I looked at the answer below, however, I seem to be making an error somewhere.

Adding x,y coordinates from table in Google Earth Engine

My CSV is structured as follows and is saved as comma-separated UTF-8. The file has 7000 lines, I have added the first 10:

y,x
50.1275,26.4817
50.1275,26.4816
40.5549,21.3141
40.5548,21.3141
46.5152,24.5436
39.0794,21.7808
39.0792,21.7808
39.0794,21.781
39.0789,21.782
39.0793,21.7811
39.0793,21.7812

Here are the steps I took:

  1. Add new -> CSV - > Select the CSV file

enter image description here

  1. Change X column to x and Y column to y. Dont touch anything else.

enter image description here

  1. Wait for file to upload, ingest.

I keep getting the following when the file is uploaded (rather than the actual plotted coordinates)

Either this: enter image description here

or a variation showing x and y as their own "float" columns

I've added this correctly before, but cant figure out where I am making the mistake. This is a previous "successful" upload: enter image description here

Here's a link to the CSV: https://drive.google.com/file/d/1GUsBqRURp6YVycyCAby3JdvzzJ0d-gsl/view?usp=sharing

Any help on this will be amazing - I'm up to ~100 slightly different attempts :/

3

When you upload the CSV, make sure to scroll down in the “Advanced options” section and enter the names of your coordinate columns here:

(Screenshot of "X column" and "Y column")

6
  • Thanks, I have changed these but still get the result above. I've tried using "latitude" & "longitude" as column headers, "x" & "y", but still end up with the lat and long as "float" columns, and "The table may not have valid geometries." where the mini-map would normally be. – Banretef Nov 4 '20 at 21:30
  • @Banretef Could you edit your question to include the text contents of your CSV file, and a screenshot of what you entered in the upload dialog? That way we can try exactly what you did. – Kevin Reid Nov 5 '20 at 1:22
  • Thanks updated! Included a link to the CSV on drive. – Banretef Nov 5 '20 at 13:17
  • 1
    @Banretef I downloaded your file and uploaded it, entering x in "X column", y in "y column" (just like your screenshot), and got a collection with points instead of numeric columns. So, I have no idea what's going wrong for you. If you can find out what's different when it fails then it might be worth filing a bug report about it because it shouldn't be this hard to upload points. – Kevin Reid Nov 5 '20 at 15:51
  • I downloaded the file, and reran the same steps and it mapped! Could be some relic in the pre-upload file (shouldn't be because there are no internal or file type changes?) Super happy it works! Thanks a lot for your help! – Banretef Nov 5 '20 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.