I have followed the steps for creating proportional symbol and multivariate analysis (QGIS docs). It looks like expected in the canvas and in the Legend Items-window in "Item properties"-tab in the Layout.

However, the symbols are not visible in the legend in the map. How may I make the symbols visible also here?

I'm using QGIS ver. 3.16.0.

enter image description here

  • Do they show if you widen the legend frame on your map? You might play around with some of the Item Properties for the legend such as spacing, position and size including the reference point.
    – John
    Nov 6, 2020 at 20:50
  • Thanks for the suggestions. However, nothing did the trick so far?!?
    – 9ls1
    Nov 8, 2020 at 11:25
  • 1
    Looks like a bug, I could reproduce that one on 3.16.0, 3.14.15, 3.10.11 and 3.4.12 on Win64bit versions. Please report it on github.com/qgis/QGIS/issues. Meanwhile you need to find a workaround, e.g. use diagrams with a similar styling or use an image as legend..
    – MrXsquared
    Nov 8, 2020 at 11:42
  • @MrXsquared, thanks for the effort in earlier versions abd for the link. I have now reported it as a possible bug.
    – 9ls1
    Nov 8, 2020 at 12:01
  • It seems to be ok in version 3.14.16 (Windows 10) according to a comment to the filed bug-report: github.com/qgis/QGIS/issues/39882
    – 9ls1
    Nov 8, 2020 at 13:09

1 Answer 1


Hurray, it's not a bug.

It is possible to make the symbols visible in the Layout.

See my detailed answer to this post I style points in QGIS 3.10.2 with two different attributes BUT the legend symbol is not visible in Layout composer.

The main point being setting a minimum value greater than zero when null.

enter image description here

See the clue given by @gioman here in the bug report Symbols from multivariate analysis not visible in legend in Layout #39882

  • Good to know. But still sounds like a bug to me. What if I dont want to display points with nodata, which is a quite common case? (rhetorical question)
    – MrXsquared
    Nov 9, 2020 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.