I have a problem when exporting to new shapefile by ArcMap 10.5. I use "add join" to join attribute from table (dbf file) to shapefile. Afterword, I need to export it to a new shapefile. It seemed to export successfully except every field contained character (text) in attribute table have been changed to number. However, this problem has not occurred in some computers with same version of ArcMap (10.5). I am not sure that this needs to be technically fixed outside ArcGIS environment or not.

Can anyone help me to solve this problem?

  • Have you tried reproducing this using a test shapefile and test DBF file?
    – PolyGeo
    Commented Nov 10, 2020 at 6:25
  • No I didn't test shapefile and DBF file. Did you mean that I have to download test shapefile AO at hub.arcgis.com/datasets/a5658170c38e4b95b5f449c88495c692_0 and test to check the problem still exist or not?
    – satha
    Commented Nov 10, 2020 at 11:08

1 Answer 1

  1. Rename normal.mxt

    C:\Users<your user name>\AppData\Roaming\Esri\Desktop10.7\ArcMap\Templates

  2. Try making a copy of the shapefile to a file geodatabase feature class, apply the join, and export it as a feature class

  3. Also you can try using the Join Field tool to make a join permanent, so try using the tool

  4. Check if all the requirements are being followed to perform Join in ArcMap

  • Hi Yogi, Thank you very much for your suggestion. However, when I tried "join field" tool to join table to shapefile. Result shown that most records appeared to be blank. However, if I tried "Add join", join is successful.
    – satha
    Commented Nov 16, 2020 at 5:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.